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Installation

Installation of Athena Visual Studio
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Download Athena Visual Studio from http://www.athenavisual.com/
Remove [if any] previous versions of Athena Visual Studio:

@ Start - Control Panel & Add or Remove Programs

When the Remove task is completed, double-click on AthenaVisualStudio.msi

To avoid problems it is recommended that you install Athena Visual Studio in the default
directory \Program Files\Athena\

In the User Information dialog the Full Name and Organization fields are optional, but
you must select the option indicated with the Radio Button below:

i& Athena Visual Studio Setup

User Information
Enter the following information to personalize yvour installation.

Full Mame: |

Qrganization: |

The settings for this application can be installed for the current user or for all users
that share this computer. You must have administrataor rights to install the settings faor
all users, Install this application for:

(%) Anyone who uses this computer

) Only for me (Michael Caracotsios)

[ < Back " Mext = ] [ Cancel

Click Next > to start the installation process.

Continue until the installation process is completed. When the installation is done,

Open Athena Visual Studio and follow the instructions below to obtain Authorization.
After the Authorization process is completed,

Test and Configure the g95 Fortran compiler by following the steps outlined below and,
Run an Athena Visual Studio example under Windows XP, 7 or Vista as shown below.


http://www.athenavisual.com/

Authorization
Authorization for Corporate License Users

» Open Athena Visual Studio. The following dialog box appears.

Athena Visual Studio E]|E|E]

LOCKED

{* Enter application

Sernal number

Cancel | | Continue >

» Enter your Serial number in the white text box.
» Click Continue >> after a brief delay you will enter Athena Visual Studio
> The very first time you enter the Athena Visual Studio development environment, you

will see the following message in the dialog box that appears:

Athena Visual Studio

» | } Restart Athena Visual Studio for the Activation to Take Effect.

» Click OK to close the dialog box and restart Athena Visual Studio.
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Authorization for Individual Commercial License Users

» Open Athena Visual Studio. The following dialog box appears

Athena Visual Studio E]|E|E]

Site code MID

CR3BEECLC FFI0-F303-3DE1-AE1C

Daps left: ] Uses left; | HAA

g LOCKED

Activation code

f* Unlock application

E-mail codes

Cancel | | Continue > |

Click E-mail codes. If your mail server does not open up, copy and paste the Site and
MID codes and e-mail them to: Tech.Support@AthenaVisual.com. Click Cancel to exit.
Within 48 hours you will receive your Activation code.

Open Athena Visual Studio again.

Enter your Activation code in the white text box.

Click Continue >> after a brief delay you will enter Athena Visual Studio

The very first time you enter the Athena Visual Studio development environment, you
will see the following message in the dialog box that appears:

VVVVYVY 'V

Athena Visual Studio

. | ,) Restart Athena Visual Studio for the Activation to Take Effect.

» Click OK to close the dialog box and restart ATHENA VISUAL STUDIO.
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Authorization for Academic and Student License Users

» Open Athena Visual Studio. The following dialog box appears

Athena Visual Studio E]|E|E]
Site code MID
CHEZBEECC FFA0-F303-30B1-0E1C
Daps left: ] Uses left; | HAA
i LOCKED

Activation code

f* Unlock application

E-mail codes

Cancel | | Continue > |

Click E-mail codes. If your mail server does not open up, copy and paste the Site and
MID codes and e-mail them to: Tech.Support@AthenaVisual.com. Click Cancel to exit.
Within 48 hours you will receive your Activation code.

Open Athena Visual Studio again.

Enter your Activation code in the white text box.

Click Continue >> After a brief delay you will enter Athena Visual Studio

The very first time you enter the Athena Visual Studio development environment, you
will see the following message in the dialog box that appears:

VVVVYVY 'V

Athena Visual Studio

. | ,) Restart Athena Visual Studio for the Activation to Take Effect.

» Click OK to close the dialog box and restart Athena Visual Studio.
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Extension for Academic and Student License Users

The Academic Research and Student License is limited to 365 days (with the exception of the
principal investigator or professor who has purchased the software. The license for the principal
investigator or professor does not have an expiration date). Ten days prior to the expiration of the
license you will see the dialog box shown below every time you start Athena Visual Studio. When
that happens please follow the instructions below to renew your license for 365 days more.

Athena Visual Studio

Hext Site code Mext WID

21EE-45F5-DEFC-7OF3

Days left: 1 Usges left; | M2

(" Enter application LICEMSED

Activation code

i+ Extend license

" Remove license

E-mail codes

Cancel | | Continue >3

» Select Extend License. The Athena Visual Studio License Manager generates the Next
Side Code and Next MID.

Click E-mail codes. If your mail server does not open up, copy and paste the Next Site
and Next MID codes and e-mail them to: Tech.Support@AthenaVisual.com. Click
Cancel to exit.

Within 48 hours you will receive your Activation code.

Open Athena Visual Studio again.

Select Extend License again.

Enter your Activation code in the white text box.

Click Continue >> After a brief delay you will enter Athena Visual Studio

A\
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» You may again see the following message in the dialog box:

Athena Visual Studio E

L]
\]‘_) Restart Athena Visual Studio for the Activation to Take Effect.

» Click OK to close the dialog box and restart Athena Visual Studio.

Execution

Test the g95 Fortran compiler

/
o0

Open an MS-DOS window: [Start = Run = cmd]

At the command prompt type: g95

Next at the command prompt type: Set Library Path
% You should see the following (or a similar display):

>

R/
*

X/
X

>

e C:AWINDOWS\system32\cmd. exe

isoft Windows Versia . 2600]
opyright 1985-2001 Micros u'I't Carp.

wcuments and Settings\Michael>gds
no input Tiles

C:"Documents inu:l settings\Michael=set Tibrary_ pi‘th
ARY_PATH=C:%Program Files‘Athena‘gd35%1ib;C: \Program Files\Athenalg95'1ib\gcc-T1bY1686-pc-mingw324.0.4

C:%Documents and Settings\Michaels_

¢ If you do not see the responses shown in the MS-DOS window above, the Path and/or
the Library_Path environment variables were not set correctly. This may happen if you
do not have the proper administrative rights on your computer. In this case, you may
request an IT person with administrative rights to reinstall Athena Visual Studio by
following the steps outlined above, or alternatively, you may configure the g95 Fortran
compiler by following the steps outlined in the section below.

L)
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Configure the g95 Fortran compiler

% Open Athena Visual Studio.

% From the Tools menu choose Options and then select the Editor and Compiler tab.

General Information |  Model Build | Editor and Compiler | 995 Compiler

Spreadsheet Enter Key Action Popup Menus and Open Dialogs
= Mext i Left {+ Edit Menu
v Down {  Right " Buid Menu |V Always Shell Process
Spreadsheet Edit Mode Select Fortran Compiler
[~ Permanent [ Arrow Keys Exit " Intel Compiler a
L]
[v Replace Text | Process Tab Key " Compag Compiler
Start in:
|C:'\F‘rugrﬂm Filezg\Athena\Samples oK | Cancel | Help

+«+ From the Select Fortran Compiler group choose the g95 Compiler
¢ Next Select the Model Build tab.

General [nformaﬁonT iModel Buildk T Editor and Eomp]lerT g95 Compiler

Build Control Options Athena Fortran Modules

Iv Treat Warnings az Errors [~ Use Athena Utilitiez Module

v Set Kinds of Reals to Double Precision [

[ Compile with the Full Traceback Option [ Use Automatic Differentiation Module

Batch Control File Directive
[v Save Uzer Allocatable Variables

Keep the Ath Batch Control File
| Keep the Athena Batch Control Fi [v Allow Integration of Blocks of Data

v Setthe Fortran Environment Variables ¥ Link Athena Libs to Stand Alone Fortran
Start in:
|C:".F‘rugrﬂrn Filez\Athena\Samples OK | Cancel | Help

®,

+ Click the Set the Fortran Environment Variables check box.

R/

++ Click OK and continue to the next step to run an example.
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Run an Athena Visual Studio Example — Windows XP

% Open Athena Visual Studio.
From the File menu, click Open and navigate to \Program Files\Athena\Samples folder.
% Select the Algebraic Models folder.

X4

+» Select the Alg01.avw example and click Open
«+ From the File menu, select Properties and then Project Description...
% You may read the description of the problem you are solving and then click Close

< From the File menu, click Save [This action generates the Fortran code Alg01.FOR. To view the
Fortran code from the View menu select Fortran Code; close this window when you are done]

% From the Build menu, click Compile [This action generates the Alg01.0BJ file]

< From the Build menu, click Build EXE [This action generates the Alg01.EXE file]

% From the Build menu, click Execute [This action runs the executable and displays the results]
+« From the File menu, click Close to close your active project.
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Run an Athena Visual Studio Example — Windows 7 or VISTA

The \Program Files\Athena\Samples folder that was created during the installation may be
restricted if the UAC (User Account Control) is enabled. Microsoft recommends that in order to
foster safer computing, the User Account Control service and policy must be enabled and
uncorrupted. Windows Security Center monitors the status of User Account Control and notifies
the user if User Account Control has been changed to a setting that's at odds with the
recommended settings.

If you wish to run any of the examples that are in the \Program Files\Athena\Samples folder
you can do one of the following:

+«+ Disable the UAC (User Account Control) by following the steps indicated below:

Launch MSCONFIG from the Run menu.

Click on the Tools tab. Scroll down till you find "Disable UAC"

Press the Launch button.

A CMD window will open. When the command is done, you can close the window.
Close MSCONFIG. You need to reboot the computer for changes to apply.

Reboot the computer.

Open Athena Visual Studio.

Follow the steps outlined under Windows XP.

YV V.V V V V VYV V

X/
°e

If you do not want to disable the UAC option you may run the examples that come with the
Athena Visual Studio installation after you save them in a folder with no restricted use.
Usually this is the folder under the name Users. You may then select to save your project in
the Documents folder under your user name, or you may wish to create a new Athena
Examples folder that you can use for your work. If you like, you may copy the entire
\Program Files\Athena\Samples under the \Users\<yourUserName>\Documents
directory, and then, open Athena Visual Studio and follow the steps outlined under
Windows XP but this time, navigate with your Windows explorer to the appropriate folder
that contains the Athena Samples.
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Athena Visual Studio Installation in User Selected Folder

If you have installed Athena Visual Studio in a folder other than the default one that was indicated
in the installation program, you must make changes to the pertinent environment variables that are

related to the g95 Fortran compiler. To do that, open the Windows Explorer and navigate to the

folder:

Select the file G95Vars.bat, do a right mouse click and select Edit; the following window will

[<Your Installation Folder>]\Athena\Bin

open with your default editor:

rem
LEm
rem
rem

3ET

SET
3ET

rem
rem
rem

SET
3ET

rem
rem
rem

This Batch File iz used t©

-

Windows 7 or Vista specif

dows NI, Windows XF,
Y PATH environment.

Replace with your
stallation Folder

595_COMPILER=C:“FROGRAM FILE3

PATH=%G95_COMFILER%‘\ATHENZM\BIN;%G95_COMPILER%ATHENA\GISA\BIN; $FATHE
LIBRARY PATH=%G95 COMPILER%‘ATHENZ‘\GS54LIB

Bequired for Windows 7 or Vista.

PATH=%G95_COMPILER%\Athena‘gd5\libhgcoc-1lib\if86-pe-mingw32h4.0.4;$PATHS
LIBRRRY PATH=%G35_COMPILER%\Athena'gdsilibh\gcoc-lib\i&86-pc-mingw32h4.0.4;3LIBRARY PATH:

Athene Visual Software, Inc.

Change the G95_COMPILER environment variable to reflect your installation folder and then
save your changes. Now try again to run an example. If you continue to have problems please do

not hesitate to contact us at: Tech.Support@AthenaVisual.com
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