Athena Knowledge Base

The Athena Visual Studio Knowledge Base contains a number of tips, suggestions and how to’s that
have been recommended by the users of the software. We will continue to enhance this knowledge
base in order to serve the needs of the engineering and scientific community.



How to Select the Fortran Compiler

To select one of the Fortran Compilers used by Athena Visual Studio do the following:

» Open Athena Visual Studio

» From the Tools menu choose Options

General Inform aﬂonT Model Build TEEditﬂ-r and Com DilerﬁT

Spreadsheet Enter Key Action Popup Menus and Open Dialogs
~ Next ( Left {+ Edit Menu
& Down " Right (" Buid Menu [ Always Shell Process
Spreadsheet Edit Mode Select Fortran Compiler
[~ Permanent [~ Arrow Keys Exit {+ Intel Compiler
{~ g95 Compiler
|+ Replace Text | Process Tab Key " Compag Compiler
Start in:
|C.:*.F‘rugram File=\Athena\zamples OK Cancel Help

» Click the Editor and Compiler tab

» Select the compiler you wish to use and click OK

Athena Visual Studio has been designed to work with three Fortran 95 compilers. The g95 Fortran
compiler which is free and comes with the Athena installation package, the Compaq Visual Fortran
compiler and the Intel Visual Fortran 95 compiler which must be purchased separately by the user.
The Compagq Visual Fortran compiler is no longer available for purchase but is widely used by the
engineering and scientific community. Detailed information about the current development activities
for the g95 Fortran compiler can be found at www.g95.org


http://www.g95.org/

How to Declare Variables and Constants in Athena

Global Variables: To declare global variables in the Athena Visual Studio environment you must use
the Global keyword as the examples below illustrate:

Global x,y, z, krate As Real
Global Skount As Integer

Global myName As Character
Global myDecision As Logical

In the above statements the variables X,y,z,krate will be treated as double precision and will be
accessible by all parts of the modeling code. Similarly the variable Skount will be treated as integer
and be accessible through out all the modeling sections. Character variables are assigned as
Character*132 from the Athena Visual Studio parser. Vectors and matrices can be declared in a
similar manner. The array size, type and number of dimensions are declared with the Global
statement. The elements of the array can be referenced by an integer index number, which runs from
one to the maximum number declared in the Global statement:

Global y(10), a(4,50), b(2,4,6) As Real
Global istate(5) As Integer

Local Variables: To declare local variables in the Athena Visual Studio environment you must use
the Dim keyword as the examples below illustrate:

Dim z, krate As Real
Dim X,y As Single
Dim Skount As Integer

In the above statements the variables z krate will be treated as double precision, while the variables
x,y will be treated as single precision and will be accessible only at the section where they have been
declared. Similarly the variable Skount will be treated as integer and will be accessible only by the
corresponding modeling section where it has been declared. Vectors and matrices can be declared in
a similar manner. The array size, type and number of dimensions are declared with the Dim
statement. The elements of the array can be referenced by an integer index number, which runs from
one to the maximum number declared in the Dim statement:

Dim x(10), b(4,50) As Real
Dim istate(5) As Integer

Parameter Statement: Use the Parameter keyword to define named constants as the examples
below illustrate:

Parameter y=2.0, z=4.0 As Real
Parameter Skount=1 As Integer

In the above statements the variables y,z will be treated as double precision and will be accessible by
all parts of the modeling code. Similarly the variable Skount will be treated as integer and will be
accessible through out all the modeling sections. The Parameter keyword is only allowed in the Data
section of the Athena Visual Studio modeling code. If it is used in the other modeling sections it will
be ignored. You may view the generated Fortran code to see how the parser interprets the Parameter
keyword.



Important Note: Always remember to declare all of your variables. Athena treats Real variables as
double precision, Integer variables as 4-byte integers, Character variables as Character*132 and
Logical variables as .True. or .False. Single precision variables are only allowed if are declared as
local with the Dim keyword.

Fortran 95 Declaration Statements: You can insert Fortran 95 declaration statements by prefixing
them with the double dollar sign. Below please see a list of Fortran 95 declaration statements that you
can insert in your Athena code. Consult your Fortran 95 manual for the syntax rules of variable and
constant declarations:

$$Integer, Parameter:: dp=Kind(1.0D0)
$$Integer, Parameter:: sp=Kind(1.0)
$$Real(Kind=dp):: v1,v2

$$Real(Kind=sp), Dimension(3):: a1,a2
$$Integer:: 11, 12

$$Character(Len=3):: s2,s3
$$Character(Len=10), Dimension(2):: s1
$$Logical:: Done

$$Real(Kind=dp), Dimension(:), Allocatable:: w

Fortran 95 Type Declaration Statements: You can insert Fortran 95 declaration Type statements
by prefixing them with the double dollar sign. If there is a large number of Type variables it is
recommended that be inserted in a Module. Below please see an example of a Type variable:

$$Type Employee

$$ Character(Len=20):: LastName
$$ Integer:: Age

$$End Type Employee

Use the following statement to declare a variable as Type Employee:

Dim Michael As Type(Employee) or
$$Type(Employee) Michael

and then you may enter data as follows:

Michael%lLastName="Caracotsios’
Michael%Age=35



How to Compile and Link with the g95 Fortran
Compiler

First you must select the g95 Fortran Compiler; then follow the instructions outline below:

» Open an MS-DOS Window.

Windows XP Windows 7 or Vista

Click Start Click Start
e & = &/'b'é'mc'mrﬁ'('ﬁl'"éiﬁamb'?éé'é"éﬁfé'f"
"'Wb’é"'é}ﬁa"'éﬁa"5'r'é§§'éﬁféf ...............................................................................

» At the MS-DOS command prompt type g95 and press enter.
»Next at the MS-DOS command prompt type Set Library_Path and press enter

You should see the logo for the g95 Fortran Compiler as indicated below. (Note that the actual
message might be different depending on the operating system, the version of the compiler that you
are using and the default folder of the emd Windows command).

AWINDOWS\system32\cmd. exe
[ . 2600]
Corp.

yments and Settings\Michael=g35
y input files

ibrary_path
% 11b; C:\Program Files\Athena',g95%1ibYgcc-T1bYi686-pc-mingw32\4.0.4

C:\Documents and Settings\Michael=_

If you do not see the above message, Athena will be unable to compile and link your project. This
may happen if you do not have the proper administrative rights on your computer. In this case, you
may request an IT person with proper administrative rights to reinstall Athena Visual Studio, or
alternatively, you may configure the g95 Fortran compiler by following the steps outlined below:



» Open Athena Visual Studio
» Form the Tools menu select Options

General Inform at‘mnT Model Build T Editor and Com p]JerT

Build Control Options Athena Fortran Modules

[v Treat Warnings as Errors [ U=e Athena Utiltiez Module

[v Set Kinds of Reals to Double Precizion [

[ Compile with the Full Traceback Option [ U=e Automatic Differentiation Module

Batch Control File Directive
[v Save Uszer Allocatable Variables

Keep the Ath Batch Control File
| Keep the =na Sateh Lontrotr [v Allow Integration of Blocks of Data

IV Set the Fortran Environment Variables ¥ Link Athena Libs to Stand Alone Fortran
Start in:
|C.:*.F'rugram File=\Athena\Samples OK Cancel Help

» Select the Model Build tab
» Click the Set the Fortran Environment Variables check box.

» Click OK to close this dialog window.

If you have installed Athena Visual Studio in a folder other than the default one that was indicated in
the installation program, you must make changes to the pertinent environment variables that are
related to the g95 Fortran compiler. To do that, open the Windows Explorer and navigate to the:

[<Your Installation Folder>]\Athena\Bin folder.

Select the file G95Vars.bat, do a right mouse click and select Edit; change the G95_COMPILER
environment variable to reflect your installation folder and then save your changes. You are now
ready to compile, build and execute your models. Follow the steps outlined below to test the compiler,
with one of the sample problems that comes with the Athena Visual Studio installation.



» Open Athena Visual Studio
» Form the File menu choose Open

P Select the \Program Files\Athena\Samples\Algebraic Equations folder

Open Model File
Look in: | I=3 Algebraic Models _v_i <= |=_~>F -
> |bmmmm
; & ALGOZ.avw
My Recent  ||&]ALGOZ.avw
Documents || g} | co4.avw
|_' ﬂ AlgD5.avw
ﬂ AlgDe.avw
Desktop ﬂ AlgD7.avw
o ﬂ AlgD&.avw
_"__}.' ﬂ Alg03.avw
ﬂ Alg10.avw
My E Algli.avw
- ﬂ AlglZ.avw
g:! ﬂ Alg13.avw
My Computer
‘g File name: IF-.LGN Y j Open
My Network  Flles of type: !.-“:thena Files {*aww) __v_! Cancel !
[ Open as read-only
2

P Select Alg01.avw and click Open
» From the File menu, click Save

» From the Build menu, click Compile then Build EXE then Execute

You should see the following window:

P, S S SS S SSSSSSSSSSSSSSSSSSSSSSSS—S—S—S———s—ssssssssss—=

Number of Algebraic EQUALIONS...cccccsnamsasess 3
Humber of Sensitivity Paramefers....cvecwcasaas
Number of User Specified IterationS.....cusees=- 30

EXIT DDAPLUS: SOLUTION FOUND

VARIABLE INITIAL GUESS BESIDUALS FINAL VALUE SENSITIVITY MATRIX
oil1) 2.00000E+00 1.57860E-14 1.20337E+00 Il -1.63213E-02 3.09127E-01 -1.47851E-01
0{2) 2.00000E+400 -4.77916E-14 1.72619E+00 Il -8.08358E-03 -3.39866E-01 3.52386E-01
T3} 2.00000E+00 -1.78677E-146 2.71318E+00 11 1.34708E-01 -4,29585E-01 3.46344E-01

Number of Newton IterationS...ceesscccassscaasass
Number of Function Evaluationd......ccieeeeasssss
Number of Jacchian EvaluBtiong.....cecesuscnasas
Number of Jacobian FactorizZationf......eseweceesa.

Lot}
oo o oo




How to Compile and Link with the Compaq Visual
Fortran Compiler

First you must select the Compaq Fortran Compiler; then follow the instructions outline below:

» Open an MS-DOS Window.

Windows XP Windows 7 or Vista

Click Start Click Start
e & = &/'b'é'mc'mrﬁ'('ﬁl'"éiﬁamb'?éé'é"éﬁfé'f"
"'Wb’é"'é}ﬁa"'éﬁa"5'r'é§§'éﬁféf ...............................................................................

» At the MS-DOS command prompt type df and press enter.

You should see the logo for the Compagq Visual Fortran Compiler as indicated below. (Note that the
actual message might be different depending on the operating system, the version of the compiler
that you are using and the default folder of the emd Windows command)

AWINDOWSsystem3 2emd. exe

M1crosott Windows XP [Version 5.1.2600)
(C) Copyright 1985-2001 Microsoft Corp.

:\Documents and Settings‘Michael»df ) )
agq Visual Fortran Optimizing Compiler Version 6.1 (Update A)
Copyright 2000 Compag Computer Corp. All rights reserved.

C:"Documents and Settings‘Michael=_

If you do not see the above message, Athena will be unable to compile and link your project. You
have therefore to set the environment variables, Path and Lib so that Athena knows where the
location of the compiler. To do that, reinstall the compiler and answer YES to the question at the end
of the installation about setting the environment variables. Alternatively, you may configure the
Compagq Visual Fortran compiler by following the steps outlined below:

» Perform a Search to find the file DFVARS.BAT
» Copy this file and paste it in the \Program Files\Athena\Bin or [<InstallDir>]\Athena\Bin folder.



After you have completed these steps do the following:
» Open Athena Visual Studio

» Form the Tools menu select Options

General [nfﬂrmaﬁonT iModel Build T Editor and Eomp]]erT

Build Control Options

Athena Fortran Modules

[v Treat Warnings as Errors [ U=e Athena Utiltiez Module

[v Set Kinds of Reals to Double Precizion [

[ Compile with the Full Traceback Option [ U=e Automatic Differentiation Module

Batch Control File Directive

[v Save Uszer Allocatable Variables
[~ Keep the Athena Batch Control File

[v Allow Integration of Blocks of Data
[+ Set the Fortran Environment Wariables

[v Link Athena Libs to Stand Alone Fortran

Start in:

|C.:*.F'rugra m Fileg\Athena\Samplez OK Cancel Help

» Select the Model Build tab

» Click the Set the Fortran Environment Variables check box
» Click OK to close the dialog window

You are now ready to compile, build and execute your models. Follow the steps outlined below to test
the compiler, with one of the sample problems that comes with the Athena Visual Studio installation.



» Open Athena Visual Studio
» Form the File menu choose Open

P Select the \Program Files\Athena\Samples\Algebraic Equations folder

Open Model File
Look in: | I=3 Algebraic Models _v_i <= |=_~>F -
> |bmmmm
; & ALGOZ.avw
My Recent  ||&]ALGOZ.avw
Documents || g} | co4.avw
|_' ﬂ AlgD5.avw
ﬂ AlgDe.avw
Desktop ﬂ AlgD7.avw
o ﬂ AlgD&.avw
_"__}.' ﬂ Alg03.avw
ﬂ Alg10.avw
My E Algli.avw
- ﬂ AlglZ.avw
g:! ﬂ Alg13.avw
My Computer
‘g File name: IF-.LGN Y j Open
My Network  Flles of type: !.-“:thena Files {*aww) __v_! Cancel !
[ Open as read-only
2

P Select Alg01.avw and click Open
» From the File menu, click Save

» From the Build menu, click Compile then Build EXE then Execute

You should see the following window:

P, S S SS S SSSSSSSSSSSSSSSSSSSSSSSS—S—S—S———s—ssssssssss—=

Number of Algebraic EQUALIONS...cccccsnamsasess 3
Humber of Sensitivity Paramefers....cvecwcasaas
Number of User Specified IterationS.....cusees=- 30

EXIT DDAPLUS: SOLUTION FOUND

VARIABLE INITIAL GUESS BESIDUALS FINAL VALUE SENSITIVITY MATRIX
oil1) 2.00000E+00 1.57860E-14 1.20337E+00 Il -1.63213E-02 3.09127E-01 -1.47851E-01
0{2) 2.00000E+400 -4.77916E-14 1.72619E+00 Il -8.08358E-03 -3.39866E-01 3.52386E-01
T3} 2.00000E+00 -1.78677E-146 2.71318E+00 11 1.34708E-01 -4,29585E-01 3.46344E-01

Number of Newton IterationS...ceesscccassscaasass
Number of Function Evaluationd......ccieeeeasssss
Number of Jacchian EvaluBtiong.....cecesuscnasas
Number of Jacobian FactorizZationf......eseweceesa.

Lot}
oo o oo




How to Compile and Link with the Intel Visual
Fortran Compiler version 10

First you must select the Intel Fortran Compiler; then follow the instructions outline below:

» Perform a Search to find the file IFORTVARS.BAT
» Copy this file and paste it in the \Program Files\Athena\Bin folder.

If you have installed Athena in a different folder simply copy the IFORTVARS.BAT file into the
[<InstallDir>]\Athena\Bin folder. Please note that there may be more than one IFORTVARS.BAT;
make sure you select the right one for your Intel Fortran installation.

After you have completed these steps do the following:

» Open Athena Visual Studio

» Form the Tools menu select Options

General Inform at‘mnT Model Build T Editor and Com p]JerT

Build Control Options Athena Fortran Modules

[v Treat Warnings as Errors [ U=e Athena Utiltiez Module

[v Set Kinds of Reals to Double Precizion [

[ Compile with the Full Traceback Option [ U=e Automatic Differentiation Module

Batch Control File Directive
[v Save Uszer Allocatable Variables

Keep the Ath Batch Control File
| Keep the =na Sateh Lontrotr [v Allow Integration of Blocks of Data

IV Set the Fortran Environment Variables ¥ Link Athena Libs to Stand Alone Fortran
Start in:
|C.:*.F'rugram File=\Athena\Samples OK Cancel Help

» Select the Model Build tab
» Click the Set the Fortran Environment Variables check box.

» Click OK to close this dialog window.

You are now ready to compile, build and execute your models. Follow the steps outlined below to test
the compiler, with one of the sample problems that comes with the Athena Visual Studio installation.



» Open Athena Visual Studio
» Form the File menu choose Open

P Select the \Program Files\Athena\Samples\Algebraic Equations folder

Open Model File
Look in: | I=3 Algebraic Models _v_i <= |=_~>F -
> |bmmmm
; & ALGOZ.avw
My Recent  ||&]ALGOZ.avw
Documents || g} | co4.avw
|_' ﬂ AlgD5.avw
ﬂ AlgDe.avw
Desktop ﬂ AlgD7.avw
o ﬂ AlgD&.avw
_"__}.' ﬂ Alg03.avw
ﬂ Alg10.avw
My E Algli.avw
- ﬂ AlglZ.avw
g:! ﬂ Alg13.avw
My Computer
‘g File name: IF-.LGN Y j Open
My Network  Flles of type: !.-“:thena Files {*aww) __v_! Cancel !
[ Open as read-only
2

P Select Alg01.avw and click Open
» From the File menu, click Save

» From the Build menu, click Compile then Build EXE then Execute

You should see the following window:

P, S S SS S SSSSSSSSSSSSSSSSSSSSSSSS—S—S—S———s—ssssssssss—=

Number of Algebraic EQUALIONS...cccccsnamsasess 3
Humber of Sensitivity Paramefers....cvecwcasaas
Number of User Specified IterationS.....cusees=- 30

EXIT DDAPLUS: SOLUTION FOUND

VARIABLE INITIAL GUESS BESIDUALS FINAL VALUE SENSITIVITY MATRIX
oil1) 2.00000E+00 1.57860E-14 1.20337E+00 Il -1.63213E-02 3.09127E-01 -1.47851E-01
0{2) 2.00000E+400 -4.77916E-14 1.72619E+00 Il -8.08358E-03 -3.39866E-01 3.52386E-01
T3} 2.00000E+00 -1.78677E-146 2.71318E+00 11 1.34708E-01 -4,29585E-01 3.46344E-01

Number of Newton IterationS...ceesscccassscaasass
Number of Function Evaluationd......ccieeeeasssss
Number of Jacchian EvaluBtiong.....cecesuscnasas
Number of Jacobian FactorizZationf......eseweceesa.

Lot}
oo o oo




How to Compile and Link with the Intel Visual
Fortran Compiler version 11

First you must select the Intel Fortran Compiler; then follow the instructions outlined below:

» Perform a Search to find the file IFORTVARS_IA32.BAT

» Copy this file, paste it in the C:\Program Files\Athena\Bin folder and rename it to
IFORTVARS.BAT.

If you have installed Athena Visual Studio in a different folder simply copy, paste and rename the
IFORTVARS_IA32.BAT file into the [<InstallDir>]\Athena\Bin folder. Please note that there may be
more than one IFORTVARS_IA32.BAT; make sure you select the right one for your Intel Fortran
installation.

After you have completed these steps do the following:

» Open Athena Visual Studio

» Form the Tools menu select Options

General InformaﬂonT Model Builck T Editor and Comp]]erT

Build Control Options Athena Fortran Modules

[v Treat Warnings as Errors [ U=e Athena Utiltiez Module

[v Set Kinds of Reals to Double Precizion [

[ Compile with the Full Traceback Option [ U=e Automatic Differentiation Module

Batch Control File Directive
[v Save User Allocatable Variables

Keep the Athena Batch Control File
B - [v Allow Integration of Blocks of Data

IV Set the Fortran Environment Variables ¥ Link Athena Libs to Stand Alone Fortran
Start in:
|C.:*.F‘rugram File=\Athena\zamples OK Cancel Help

» Select the Model Build tab
» Click the Set the Fortran Environment Variables check box.

» Click OK to close this dialog window.



You are now ready to compile, build and execute your models. Follow the steps outlined below to test
the compiler, with one of the sample problems that comes with the Athena Visual Studio installation.

» Open Athena Visual Studio
» Form the File menu, choose Open

» Select the \Program Files\Athena\Samples\Algebraic Equations folder

Open Model File
Look in: | I=3 Algebraic Models ___'_j = % Ef-
| '-5- ElaLcoLavw]
| &) ALGOZ.avw
My Recent  ||&]ALGOZ.avw
Documents | %) o Go4.avw
[' ﬂ Algd5.avw
ﬂ Algls.avw
Desktop ﬂ Alg07.avw
o ﬂ Alg0&.avw
’-J ﬂ Alg09.avw
ﬂ Alg10.avw
My ﬂ Alg1l.avw
- ﬂ Alg12.avw
g:! ﬂ Alg13.avw
My Computer
‘g File name: IF-.LGN e _11 Open
MyNetwork  Flesoftype:  [Athena Fies ("avw) =l Cancel |
[~ Open as read-only
b

P Select Alg01.avw and click Open



» From the File menu, click Save
» From the Build menu, select Fortran and Code Generation Options

» Insert the Additional Options indicated in the image below [-Qvc7.1 —threads]

+ Fortran Compilation Options

i~ Intel Fortran Compilation Options. -

jl:u rrent Options:

]—nnlngn -extend_source: 132 -warn:errors

Ix-dd itional Option=s:

i—CM:Tj threads| Clear

iln clude Directories:

‘ Browse. .
OK ] Cancel Help

» From the Build menu click Compile then Build EXE then Execute

You should see the following window:

Number of Algebraic EqUaticns.......c.covuueean. 3
Number of Sensitivity PArameierS.......eswsesea- 3
Number of User Specified Iterationsd.....eeeess. 30

EXIT DDAFLUS: SOLUTION FOUND

VARTABLE INITIAL GUESS RESIDUALS FINAL WVALUE SENSITIVITY MATRIX
(1) 2.00000E+00 1.57860E-14 1.20337E+00 Il -1.83213E-02 3.09127E-01 -1.47851E-01
iz} 2.00000E+00 -4.77916E-146 1.72615E+00 Il -5.068358E-03 -3.3986€E-01 3.52386E-01
0{3) 2.00000E+00 -1.78677E-14 2.71318E+00 11l 1.34708E-01 -4.29585E-01 3.48344E-01

Number of Newton Iterationg..eesceeccsnancasssss
Number of Function EvaluRtiong.....cecesswscaasas 3
Number of Jacobian EvVEIUBTIONS....ccecannncnaaas
Number of Jacobien Factorizations...............

oo o oo

Note: If the Additional Options inserted above generate compilation or linking errors and warnings,
remove them and try again. If you are still having problems contact tech.support@athenavisual.com.



mailto:tech.support@athenavisual.com

How to Obtain Information about the Fortran
Compilers

You may obtain more information about the Fortran Compilers in Athena Visual Studio as follows:

» Open Athena Visual Studio

» From the Help menu select Fortran Compilers.

s Athena Visual Studio

File Edit Model Build View Format Tools Visualkinetics Windows BgEisl

0 @l nl % -c @]l '}Q [__}ﬁ@ Ml o [ .ﬂ—i El. Athena Visual Studio Help

Getting Started...

Athena Solvers...
Fortran Compilers...

Book Examples. .. 3
Chemical Engineering Topics

Technical Support
Athena Tutorials...
Athena Knowledge Base

Athena on the Web...
About Athena Visual Studio

How to Obtain Information about the Athena Solvers

You may obtain more information about the Solvers in Athena Visual Studio as follows:

» Open Athena Visual Studio

» From the Help menu select Athena Solvers.

<3 Athena Visual Studio
File Edit Model Buld WView Format Tools VisualKinetics Windows R3E0]

¥ E‘;:ﬁ|@ Ml | ;Il B Athena Visual Studio Help 1 J Iii_r'| F |§§| 5"'|£| p“@-l _

Getting Started...

Athena Solvers...

Fortran Compilers. ..

Book Examples...

Chemical Engineering Topics

Technical Support
Athena Tutorials. ..
Athena Knowledge Base

Athena on the Web...
About Athena Visual Studio




How does Athena store the Sensitivity Functions

Consider the following system of Differential/Algebraic Equations

State Equations

E(t,u;e)?j—l::F(t,u;e)

t=t, u=u,(0)
Sensitivity Functions
w2

00

The following nomenclature applies in Athena Visual Studio for a differential system with 3 state
equations and 2 parameters.

ou, 8u1_

“ %6, %,

ULl U@L2) U@L3) 1 P
U@l U2 U@23)|=|u, % %
UGB U(32) U@B3) 1
g s Oy

- ° 08, 08, |




Fatal Error: While reading module "***' found module
version 8, expected 6.

This error results when the g95 Fortran Compiler version installed on your computer is older than
the one used by the current version of Athena Visual Studio. To resolve this error follow the steps that
are outlined below:

» Go to \Program Files\Athena [or the folder you installed Athena if different]
» Delete the folder g95
» Uninstall and Reinstall Athena Visual Studio

» Start Athena Visual Studio

» From the File menu click Open

» Go to \Program Files\Athena\Samples\Algebraic Equations

P Pick up the first example Alg01.avw

» Save, Compile, Build EXE and Execute to make sure the compiler works

» Now you are ready to run your models

EXE Building Messages: Id: crt2.0: No such file: No
such file or directory

This EXE Building error occurs when the environment variable LIBRARY_PATH has not been set
correctly. To resolve this error follow the steps that are outlined below:

» Open Athena Visual Studio

» From the Tools menu select Options

» Go to Model Build tab

» Click the Set the Fortran Environment Variables check box and then press OK

» Open your application and try again

If these steps do not alleviate the problem, then you most likely installed Athena and the compiler in a
directory other than the installation default \Program Files]. In this case, in addition to the steps
above you must do the following:

» Navigate with the Windows Explorer to the folder [RINSTALLDIR>]\Athena\Bin

P Select the G95vars.bat file and then, do a right mouse click and select Edit from the menu.
» Modify the G95_COMPILER environment variable to reflect your installation directory.

» Save the G95vars.bat file, then open your Application and try again.



Error: This module file was generated for a different
platform or by an incompatible compiler or compiler
release.

This error occurs when the user copies the wrong IFORTvars.bat file in the \Athena\Bin folder. To
resolve this error follow the steps that are outline below:

» Perform a Search for ifortvars.bat

» When the search is completed the Search Results window may look like the image below:

IFORTvarsbat C:Program Files\Athena\Bin 2KB MS-DOS Batch File
Fifortvars.bat C:\Program Files\Intel\Compiler \Fortran' 10.0,025\ema4t bin 1KB M3-D0S Batch Fle
ifortvars.l:nat C:Program Files\Intel\Compiler \Fortran' 10,0,025\14 32 Bin 2KB MS-DOS Batch File
ifortvars.hat C:\Program Files\Intel\Compiler \Fortran' 10, 0.025\Ttanium|Bin 1KB M3-D0S Batch Fle

» You may see more than one batch files especially if you have upgraded the Intel Visual Fortran
Compiler from an earlier version

P Select the batch file that corresponds to the correct Intel Visual Fortran version that is installed in
your computer

» Select the batch file that is located in the IA32\Bin folder
» Copy this file into the \Athena\Bin folder

» Reopen your Athena project, Save it and proceed to Compile, Build the EXE and Execute it.

IFORT: error #10037: could not find ‘link’

This error occurs when the user copies the wrong IFORTvars.bat file in the \Athena\Bin folder. To
resolve this error follow the steps that are outline below:

» Perform a Search for ifortvars.bat

» When the search is completed the Search Results window may look like the image below:

IFORTvarsbat C:Program Files\Athena\Bin 2KB MS-DOS Batch File
Fifortvars.bat C:\Program Files\Intel\Compiler \Fortran' 10.0,025\ema4t bin 1KB M3-D0S Batch Fle
ifortvars.l:nat C:Program Files\Intel\Compiler \Fortran' 10,0,025\14 32 Bin 2KB MS-DOS Batch File
ifortvars.hat C:\Program Files\Intel\Compiler \Fortran' 10, 0.025\Ttanium|Bin 1KB M3-D0S Batch Fle

» You may see more than one batch files especially if you have upgraded the Intel Visual Fortran
Compiler from an earlier version

P Select the batch file that corresponds to the correct Intel Visual Fortran version that is installed in
your computer

» Select the batch file that is located in the IA32\Bin folder
» Copy this file into the \Athena\Bin folder

» Reopen your Athena project, Save it and proceed to Compile, Build the EXE and Execute it.



How to View and Edit Athena Options in Windows
Registry.

Click on Start and Run and then type in regedit and press the Enter key. First save a copy of the
complicated system registry file so that you can restore it if you mess up while making the change(s)
needed. To do that, select File and Export to create a copy of the registry on your desktop. If you
double-click the icon this creates, your registry will return to the current settings.

To change the registry settings for Athena Visual Studio expand the folders as follows:

HKEY_CURRENT_USER

» Software

» VB and VBA Program Settings
» Athena

» Options

Scroll down to the desired item and click on it. In the box that appears, type the new settings that you
wish.



Fortran runtime error: Bad value during floating
point read

This error occurs during Parameter Estimation when the Regional Options in the user's computer
have been set to a value other that English(United States). The Regional Options can be changed
from the Windows Control Panel or from Athena Visual Studio as follows:

» Open Athena Visual Studio

» From the Tools menu select Change Regional Options

Regional and Language Options

Regional Options | Languages | Advanced
Standards and formats

This option affects how some programs format numbers, cumencies,
dates, and time.

Select an item to match its preferences, or click Customize to choose
your own formats:

English (United States) v | [(customize... |

Samples

Mumber: | 123,456,785.00
Curency:  |£123,456,789.00
Time: |6:22:40 AM
Short date: | 11/18/2008

Long date: |Tuesda'_.r. Movember 18, 2008

Location

To help services provide you with local information, such as news and
weather, select your present location:

|United States W |

oK || Cancel || Apply |

» From the drop down menu select English(United States)
» Click OK

» Close Athena Visual Studio



In order to run your parameter estimation project you need to recreate the data file required by the
Athena solvers. To do that:

» Open Athena Visual Studio

» From the File menu click Open and select your project
» Hit F12 to load the Parameter Estimation Solver

» Click OK to recreate the parameter estimation data file

» You may now Compile, Build EXE and Execute your model.

If you want to see the parameter estimation data file that Athena generates:

» From the View menu, select Parameter Estimation Data File

FATAL ERROR. Unauthorized License Has Been
Detected

This error usually occurs if you try to run a model that was created on a different computer (for
instance if a coworker has sent you his or her Athena model). If you are an authorized user of Athena
Visual Studio and receive this error follow the steps below:

» Open Athena Visual Studio

» From the File menu click Open and select your project

» From the Edit menu click Clean Up to delete all intermediate files of your current project
» From the File menu click Save to recreate the Fortran code of your current model

» You may now Compile, Build EXE and Execute your model.



Fortran Compilation and Linking Errors

The following is a list of commonly encountered warnings and errors and some helpful hints in
troubleshooting them.

Warnings: The presence of warnings in your Fortran Compilation and/or Linking output indicates that
you are using parameters or variables that you have not declared. These variables will be assigned
zero or unpredicted values by the compiler and this action may have detrimental effects on your
simulation. Make sure you remove all critical warnings before you proceed with the execution of your
program. This is ordinarily done by declaring all your model variables and constants with the Global
or Dim keywords

Syntax Errors: Syntax errors arise form statements in your model code that do not comply with
standard Fortran 77 or Fortran 90/95 rules. In most cases syntax errors are easy to correct. To do
that place your cursor on the statement that describes the syntax error and double-click. This will take
you back to your model code and highlight in the offending statement. You may then correct the
statement and recompile your model. If this does not happen, you will have to find the offending
statement manually. This is ordinarily very easy since there is often a clear description of the error.

Unresolved Externals Errors: This message arises when you try to access a subroutine or function
that you have not included in your project. The name of this subroutine or function should be given in
the following format: _Rates@0. This message means that you are trying to access the subroutine or
function Rates and the linker cannot find it anywhere. To correct this problem make sure you include
the missing subroutine or function in your project. Sometimes your subroutine is already included in
your project and you still see this message. This is an indication that you are calling the subroutine
with the wrong set of arguments. Frequently you misspell a variable and get the same message. For
example suppose that you want to type k1=3 and instead you typed k(1)=3. Then you will get an
unresolved external because the linker things you are trying to access the function k(x).



Viewing Fortran Compilation and Linking Errors

To view the compilation and/or linking errors click Yes in the Message Box at the end of the
compilation or linking process. Place your cursor on the first statement that contains the error or the
critical warning and double-click. (This will be the line In file ALGO1.FOR:124 for the example below)

Global ‘Rs Real
pl=3.62882

pa=4.0
p3=5.0

@Initial Conditions
O(l)=2.0
O{2)=2.0

[ vesy=2.0/ E Fortran Compilation Error Messages

in file ALGO1.FOR:124
@Model Equatil

Dim K1,32,13 U{3:|=2.|:|.|:
s
x1=U{1) Error: Unclassifiable statement at (1)
x2=0{2) |
x3=0(3)

F(l)=xl**3-e
F(2)=xl**2%
F(3)=xl*xa*

@Solver Optio
Param (10)=1.

If Athena locates the error it will display your model code with a blue bookmark next to the offending
statement. Correct the statement and recompile your project. Repeat this procedure, troubleshooting
one error or critical warning at a time.

If Athena is unable to locate the error then do the following. First click here to read some information
about the most commonly encountered errors. Then, read the Fortran line number that has the error
or warning. This number is 124 for our example above or it may be enclosed in parentheses
(depending on the compiler that you are using). From the View menu choose Fortran Code to see
your Fortran code. Go to the offending statement and check for errors. To go to the offending line
quickly: Make sure that your Fortran Code window is active. From the Edit Menu choose Go To.
Enter the line number (124 in our example) that contains the compilation error. Then choose OK.



Athena Visual Studio Error Messages

The following is a list of miscellaneous errors that occur during the model building process

lllegal Declaration Statement: Make sure you declare your model variables and constants correctly
using the Global and Dim keywords.

Unable to Locate Source [Object] [Library] File: You have attempted to include in your active project a

Fortran Source or Object or Library file that does not exist. Please check the name and path of the file
and try again.



Fatal Error During Installation with Windows Vista

When running the installation under Windows Vista, you may receive one of the following errors when
clicking the Next button on the Welcome Dialog:

Title: Fatal Error

Text: Installation ended prematurely because of an error

Example #1

Action ended 11:44:17: WiseNextDIg. Return value 3.
DEBUG: Error 2896: Executing action WiseNextDIg failed.
Internal Error 2896. WiseNextDlg

Action ended 11:44:17: Welcome_Dialog. Return value 3.

Example#2

Action start 11:39:42: RebuildListbox.

Action ended 11:39:42: RebuildListbox. Return value 3.
DEBUG: Error 2896: Executing action RebuildListbox failed.
Internal Error 2896. RebuildListbox

Action ended 11:39:42: Welcome_Dialog. Return value 3.
MSI (c) (A0:50) [11:39:42:282]: Doing action: Fatal_Error

This occurs when you are unable to run VBScripts on your computer. This can be due to either
VBScript being disabled or unregistered. To resolve this issue follow the steps below to register
VBscript your computer:

» Ensure the VBscript is installed.
» Turn off script blocking antivirus and personal firewall software.

» Locate the vbscript.dll on your system. On 32-bit systems, this file should be located at
C:\Windows\System32. On 64-bit systems, the file should be located at C:\Windows\SysWOWG64.

» Go to Start > Run and at the prompt enter: regsvr32.exe <path to vbscript.dll>.

Windows Vista should then confirm that the vbscript has been registered.
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